
Beim kürzlich erschienen CU2 für Citrix Virtual Apps and Desktops 2507 LTSR gab es bei einer Hand voll Sites Fehler während der Vorabtests. In den Ergebnissen wurde auf den Citrix Knowledge Base Artikel CTX216685 verwiesen, der allerdings nicht online/öffentlich verfügbar ist. Der Fehlertext schlägt auch erst einmal PowerShell Befehle vor, die aber nicht existieren:
Broker_CoreServiceConnectivity
Testet, ob Kontakt mit den Kerndiensten hergestellt werden kann.
Test wurde auf folgenden Controllern ausgeführt: <Delivery Controller FQDN>
Controller ‚<Delivery Controller FQDN>‘: Datenbank ist kompatibel, die Dienstgruppe kann registriert werden.
Führen Sie die folgenden Cmdlets aus, um die Registrierung beim zentralen Konfigurationsdienst vorzunehmen: Get-MySnapInServiceInstance | Register-ConfigServiceInstance Get-ConfigRegisteredServiceInstance -ServiceType Config | Reset-MySnapInServiceGroupMembership See CTX216685 for details. When the issues are resolved, restart the Site tests.
Diesen Fehler gab es insgesamt fünfmal im Vorabtest (Broker_CoreServiceConnectivity, Broker_PeersConnectivity, Broker_RegisteredWithConfigurationService, Broker_ValidateStoredCsServiceInstances, Broker_CheckBootstrapState).
Von den vier PowerShell Befehlen gibt es allerdings die beiden „Get-MySnapInServiceInstance“ sowie „Reset-MySnapInServiceGroupMembership“ nicht. Immerhin konnte mir hier die Citrix Support KI weiterhelfen und lieferte die korrekten Befehlen für dieses Szenario:
Add-PSSnapIn Citrix*
Get-AppLibServiceInstance | Register-ConfigServiceInstance
Get-ConfigRegisteredServiceInstance -ServiceType Config | Reset-AppLibServiceGroupMembershipNach einem Neustart des Setups liefen alle Vorabtests ohne Fehler durch und die Sites konnten auf das CU2 geupdatet werden.





Schreibe einen Kommentar