Citrix Receiver Protokollfehler mit dem Authentifizierungsdienst

Ein Protokollfehler mit dem Authentifizierungsdienst bei der Citrix Receiver Einrichtung (Windows / iOS / Android).

Anfang des Jahres „wollte“ ein Kunde seine in die Jahre gekommene XenApp 6.5 Umgebung ablösen und auf modernere Betriebssysteme updaten. In diesem Zug musste natürlich auch die Citrix Umgebung aktualisiert werden. Das verlief auch alles sehr harmonisch und nach Schema-F ab bis es zur Einrichtung an einem iPad sowie einem externen Arbeitsplatz kam. Am Arbeitsplatz (nicht in der Domäne des Kunden) begrüßte mich nach Eingabe der Server Adresse und Benutzer / Passwort folgende Meldung:

Citrix Receiver Protokollfehler Authentifizierungsdienst
Citrix Receiver Protokollfehler Authentifizierungsdienst

Das Arbeiten im Receiver for Web und auch HTML5 Receiver war vollkommen problemlos möglich. Ebenfalls konnte im Receiver for Web der Citrix Receiver for Windows über die Schaltfläche „Aktivieren…“ in Betrieb genommen werden. Ebenso konnten am iPad / iPhone in einem Browser die Anwendungen gestartet werden.

Citrix Receiver Aktivieren
Citrix Receiver Aktiviere

Nach mehrtägiger / wöchiger / monatiger Fehlersuche (mit dem Citrix Support) konnte ich im Citrix Support Forum eine weitere Lösung neben der Citrix Lösung finden.

Die Citrix Lösung: Storefront deinstallieren und nicht von der ISO neu installieren, sondern das Storefront Setup seperat herunterladen und ausführen. Danach den automatisch generierten Store umbenennen oder benutzen. Wichtig: Den „Default Store“ nach der Installation nicht löschen und einen neuen anlegen! Genau dann bekommt man das oben genannte Problem…

Die Support Forum Lösung: In der web.config (im Ordner C:\inetpub\wwwroot\Citrix\Roaming) die Zeile mit „https://<FQDN>/Citrix/Authentication/auth/v1“ im Abschnitt „<tokenManager>“ suchen und die im Screenshot rot markierte Zeile löschen.

Nach einem „iisreset“ am StoreFront Server ist die Einrichung des Citrix Receivers unter iOS (iPad / iPhone) oder auch im Citrix Receiver for Windows wieder möglich.

Hier noch der Link zur Diskussion im Citrix Support Forum: https://discussions.citrix.com/topic/376304-a-protocol-error-occured-while-communicating-with-the-authentication-service/ bzw. der entsprechende Post https://discussions.citrix.com/topic/376304-a-protocol-error-occured-while-communicating-with-the-authentication-service/page-2#entry1946776

Beteilige dich an der Unterhaltung

3 Kommentare

  1. Hat geholfen, vielen Dank! Offenbar auch heute noch ein Problem mit frisch installiertem 7.15 LTSR CU2 (Storefront 3.12.2000.8)

Schreib einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.